开发环境配置

  • Linux系统上,运行Qt出现以下错误:

Could not find Qt Platform plugin "xcb" in "" 输入图片说明 这种情况说明QT找不到平台插件。在这里,pyminer开发组内部有以下常见的解决方案,分享出来供大家参考。

解决办法

如果你的 python 是在linux系统下,使用anaconda进行包管理,很多时候可以删除虚拟环境重装一遍,这样省事。

如果 Python 不是通过 conda 安装,而是自己编译的或者系统自带的,那么重装也无济于事。仔细看 "xcb" in "",这说明 QT_QPA_PLATFORM_PLUGIN_PATH 没有找到正确位置。

进入 python3,输入

import sys
print(sys.path)

找到 python3.8/site-packages 所在路径。

输入

export QT_QPA_PLATFORM_PLUGIN_PATH={...}/python3.8/site-packages/PyQt5/Qt/plugins/platforms

注意,要把 {...} 手动替换成刚刚找到的完整路径 这时候再试试。如果报这样的错: Could not find Qt Platform plugin "xcb" in "{...}/python3.8/site-packages/PyQt5/Qt/plugins/platforms" 说明 QT_QPA_PLATFORM_PLUGIN_PATH 已经找到,还有其他错误。

  • 输入
    export QT_DEBUG_PLUGINS=1
    
    获取详细报错信息。例如常见错误是缺少libxcb-xinerama0,找到错误后就可以对症下药
    sudo apt-get install libxcb-xinerama0
    

results matching ""

    No results matching ""